Uploaded image for project: 'IGB'
  1. IGB
  2. IGBF-2009

Rework IGB Trust Certificate Dialog

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      Situation: If a user attempts to load a file in IGB via URL through HTTPS and there is no issue with the certificate, IGB will load the file. If there is an issue with the certificate, IGB will ask the user if they trust the certificate. If the user confirms that they trust the certificate, the certificate is still considered invalid and the connection refused.

      Possible Resolution: Either IGB needs to honor the user's decision or not ask the user to validate the certificate and inform them that there is an issue with the certificate.

      Task: Understand the architecture and event flow that triggers it. Implement a fix that will lead to either outcome above.

      This issue is closely related to IGBF-1362.

      Important files:
      IGBTrustManager.java
      LocalUrlCacher.java
      GeneralLoadUtils.java

        Attachments

          Issue Links

            Activity

            aloraine Ann Loraine added a comment -

            Moving to next sprint.

            noor91zahara Noor Zahara added a comment - - edited

            I tried replicating the issue using http://lorainelab-quickload.scidas.org/IGBF-1362 by changing the code in IGBTrustManager.java #checkServerTrusted to forcefully ask to trust the certificate.

            Findings

            1. If the user selects yes, then the data is getting loaded.
            2. User selects no, then an exception is thrown.

            aloraine Ann Loraine added a comment -

            Could not reproduce.


              People

              • Assignee:
                noor91zahara Noor Zahara
                Reporter:
                nfreese Nowlan Freese
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: