Uploaded image for project: 'IGB'
  1. IGB
  2. IGBF-2784

Investigate "works with" code in app store

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Story Points:
      2
    • Sprint:
      Winter 4 Feb 8 - Feb 19, Winter 5 Feb 22 - Mar 5, Winter 6 Mar 8 - Mar 19

      Description

      We currently do not have a clear policy regarding how the IGB API is allowed to change when IGB versions increment.
      And yet, the App Store displays some text indicating versions an App is compatible with.
      For this task, investigate the code base of App Store and determine which IGB-version related-rules, if any, are implemented.
      Please make note of where the business logic for determining app compatibility is implemented.

        Attachments

          Activity

          chirag24 Chirag Chandrahas Shetty added a comment - - edited

          Dr. Ann Loraine The logic of comparing versions is in app_page.js. We call setup_install function from app_page.html file which is used to decide what button and message to display.

          aloraine Ann Loraine added a comment -

          Question for Chirag Chandrahas Shetty - Have you written anything else? If yes, please attach it to the ticket.

          chirag24 Chirag Chandrahas Shetty added a comment - - edited

          Please find the attached document.

          aloraine Ann Loraine added a comment - - edited

          Please expand the attached diagram to show the different response obtained from IGB when:

          • An App with the given "symbolicName" is already installed into IGB

          Also, kindly remove the quotation marks around "AppName" because surround a string with quotations marks means that the literal value of the string is indicated. Or is that what was intended? I think it is meant to signify a variable?

          EDIT: Kindly disregard the comment. I can make the change using the Word document.

          aloraine Ann Loraine added a comment - - edited

          Also, please specify the different possible values for request payload action variable.

          EDIT: Kindly disregard the comment. I see that this is included in the attached Word document.


            People

            • Assignee:
              chirag24 Chirag Chandrahas Shetty
              Reporter:
              aloraine Ann Loraine
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: