Uploaded image for project: 'IGB'
  1. IGB
  2. IGBF-2785

Update POM to include micro version

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Story Points:
      1
    • Sprint:
      Winter 4 Feb 8 - Feb 19, Winter 5 Feb 22 - Mar 5, Winter 6 Mar 8 - Mar 19, Spring 1 2021 Mar 22 - Apr 2

      Description

      Modify the quickload app POM to specify micro versions in the MANIFEST.
      Please fork: https://bitbucket.org/lorainelab/quickload-saver.git to work on this.
      The app should be declared to depend on IGB packages versions 9.1.8 or higher, up to but not including version 10.
      I'm not sure how the App Store or the within-IGB App Manager will handle this, but I would like to investigate.

        Attachments

        1. App.PNG
          App.PNG
          205 kB
        2. change in pom.xml file.PNG
          change in pom.xml file.PNG
          28 kB
        3. Logs.PNG
          Logs.PNG
          70 kB
        4. New Manifest.PNG
          New Manifest.PNG
          48 kB
        5. Old Manifest.PNG
          Old Manifest.PNG
          48 kB
        6. Repository.PNG
          Repository.PNG
          102 kB

          Issue Links

            Activity

            aloraine Ann Loraine added a comment -

            Google doc above observes that the MANIFESTs from jars built before and after the proposed change are identical, but the proper installation behavior is only observed for the jar build using the new code.

            I do not see how that is possible. Please investigate more carefully. Note that when you install or upgrade an App, the App's bundle is downloaded and saved to the user's local bundle cache. When you un-install an App, the bundle is deleted.

            Also, investigate other meta-data assets provided in the jar.

            omarne Omkar Marne added a comment - - edited

            Dr. Loraine you were right, we were comparing the same manifest files. I have attached the snapshots again. Micro versions in the manifest files have changed. After code change in pom.xml, manifest is taking the micro versions from pom.xml.

            The app bundle is getting added and deleted when we install and uninstall the app. Also the repository.xml file has got updated with the updated micro versions.

            Please check the code review and additional snapshots attached.

            https://docs.google.com/document/d/1Jkot1-5W5g6wvYTDhw7NcZIThic_8x47Wo0irX46zcc/edit#

            Ticket is ready for pull request and assigned to Chester Dias

            aloraine Ann Loraine added a comment -

            PR is merged and App is ready for testing from Downloads folder of https://bitbucket.org/lorainelab/quickload-saver/downloads/.

            inaylor Irvin Naylor added a comment -

            Can confirm, App does indeed work as intended on 9.1.8 master, output of Homosapeins 2013 is sent to correct contents.txt file


              People

              • Assignee:
                inaylor Irvin Naylor
                Reporter:
                aloraine Ann Loraine
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: