Uploaded image for project: 'IGB'
  1. IGB
  2. IGBF-2874

Implement Link Generator URL Verification

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Story Points:
      3
    • Sprint:
      Spring 6 2021 May 31 - June 11, Summer 1 2021 Jun 14 - Jun 25, Summer 2 2021 Jun 28 - Jul 9

      Description

      Within Django App 1 - Link Generator the first step is to ensure that whatever link the user inputs is actually a valid track hub link. Otherwise, they will simply be met with a message on the entry screen stating that their URL is invalid.

        Attachments

          Issue Links

            Activity

            inaylor Irvin Naylor added a comment -

            Progress report:

            I've spent some time retrofitting some of my old code and updating the commenting on it to better fit the new forms.py and validation methods. However, I've run into something of a snag that I'm working through. Django has multiple built-in validation methods for user input and we will be using the URL verification to ensure the trackhub is an actual link (as opposed to something like a single word), as well as support for custom verification which we will be using to ensure the user's URL is pointing to the hub.txt file (is the ending of the link /hub.txt?).

            The issue is the validate_trackhub_url(value) function takes in a value as a parameter and while I have linked the user input field to send it to a variable, for some reason, even when I state the verification on top of the variable th_link, it will not validate.

            Will continue investigating but for now, aside from that, things are going rather well!

            chirag24 Chirag Chandrahas Shetty added a comment - - edited

            This ticket is an extension of IGBF-2873. We will need a form and the logic that creates the new link.

            omarne Omkar Marne added a comment - - edited

            Progress report - The GUI of the trackhub website is ready. I have made some modifications in Rachel's HTML/Bootstrap's code to make it more robust and user friendly. I have included the links and recommendations from bioviz app store.

            Currently working on the logic to validate the URL in Django.

            Please check the attached snapshot.


              People

              • Assignee:
                omarne Omkar Marne
                Reporter:
                inaylor Irvin Naylor
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: