Uploaded image for project: 'IGB'
  1. IGB
  2. IGBF-2639

Test Track Operators - Graph Tracks - MacOS

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:

      Attachments

      1. 9.1.4-graphOperations1.png
        9.1.4-graphOperations1.png
        106 kB
      2. 9.1.4-graphOperations2.png
        9.1.4-graphOperations2.png
        117 kB
      3. graphOperations1.png
        graphOperations1.png
        127 kB
      4. graphOperations2.png
        graphOperations2.png
        114 kB
      5. InverseOperation.png
        InverseOperation.png
        126 kB
      6. MultiTrackOperation.png
        MultiTrackOperation.png
        80 kB

        Issue Links

          Activity

          ssegu Sai Supreeth Segu added a comment -

          When I am performing the inverse operation, the graph was shown empty, and then I adjusted the Max Value which showed the graph clearly.

          ssegu Sai Supreeth Segu added a comment -

          Inverse, Natural Log and Log3 graphs are not generated with pink tracks instead new green tracks are generated

          ssegu Sai Supreeth Segu added a comment -

          Inverse function generated by the new code is wrong. Earlier version generated correct inverse function

          ssegu Sai Supreeth Segu added a comment -

          Please find graphOperations2 images for the difference between inverse Log2 and inverse Log10. Both the versions are generating wrong results

          ssegu Sai Supreeth Segu added a comment -

          Please find graphOperations1 images for the difference between inverse Log3 and inverse Natural Log. Both the versions are generating wrong results

          ssegu Sai Supreeth Segu added a comment -

          These values are generating correctly when I first generate a log of the graph and then generate an inverse for the log graph but when I directly generate inverse log functions in the dropdown, these values are not correct.

          Go to the Selection Info panel and verify that all tracks have the expected y coord corresponding to the original value of 16:

          Mac
          inverse of log (16, base=3): 0.3962406
          inverse of log (16, base=2): 0.25
          inverse of log (16, base=10): 0.830482
          inverse of natural log of 16: 0.3606738

          ssegu Sai Supreeth Segu added a comment -

          While I was performing multi-track operations, If I first select Even numbers and then odd numbers track, only the first operation we select under multi-track is generating with a green graph and all the other operations are created with blue graphs(same happens in 9.1.4 version also). Even the values generated are different from expected for all the graphs except for the first graph.

          aloraine Ann Loraine added a comment -

          The issues above are related to order of selection and selection history. The problem is due to lack of clarity over how to specify argument order when performing a track operation. This is a usability issue that needs to be addressed in future releases.


            People

            • Assignee:
              ssegu Sai Supreeth Segu
              Reporter:
              aloraine Ann Loraine
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: