Uploaded image for project: 'IGB'
  1. IGB
  2. IGBF-2007

Investigate inability to open files on Apple Mojave OS

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:

      Description

      IGB user reports:

      "I am a big fan of the Integrated Genome Browser. In my opinion, IGB is the fastest and most intuitive genome browser available.

      Unfortunately, recently, I was unable to use IGB on my MacBook Pro (installed with Majove 10.14.5 and Java 1.8.0_221-b11). I was able to start up the software and select my favorite genome (S. cerevisiae). I could see the gene tracks and was able to select different chromosomes. But when I tried to open files from my computer, the 'rainbow' spinning wheel appeared and the window for file selection never opened. I had to 'force quit' IGB in order to make the spinning wheel go away. I was able to run IGB on an older MacBook with an earlier version of the MacOS. Therefore, I suspect the problem may be related to Majove.

      I hope you could kindly look into the problem, as I suspect other Mac users may have similar experience."

      When we have some better idea about the problem, we can contact the reporter of this bug with updates. Ask Ann Loraine or Nowlan Freese for contact info.

      Suggestions:

      • IGB is using a native file chooser. Apple may have changed how Java
        programs must interact with this. I would look at that first.
      • We may need to do a minor release with fix. To reduce time required for testing, we might want to branch from the release branch and then cherry-pick changes it to the master branch as required.

        Attachments

          Issue Links

            Activity

            nfreese Nowlan Freese added a comment -

            I was using IGB version 9.0.2 when I realized the file opening problem. I have recently installed the pre-release IGB 9.1.0, hoping that the newer version could solve the problem. But I still experience the same issue.

            The problem with file opening also happens with other genomes, including human. I have attached the problem report after 'force quit' with this email.

            The lockup is not caused by any file type, as it occurs before file selection. The spinning wheel appears after clicking File > Open File.

            nfreese Nowlan Freese added a comment -

            I (Nowlan) am running macOS Mojave 10.14.6 (current update as of Sept. 9, 2019) and Java build 1.8.0_221-b11 and cannot currently reproduce the issue.

            aloraine Ann Loraine added a comment - - edited

            Sorry Noor Zahara - this is not ready for you to work on.

            We did some trouble-shooting with the person who reported this and are waiting to hear from him. I'm guessing the software is working for him now. I should have given this a "cannot reproduce" resolution rather than leave it in "to do".


              People

              • Assignee:
                noor91zahara Noor Zahara
                Reporter:
                aloraine Ann Loraine
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: